Got no response for wallet request ... trying to solo mine with creep miner 1.5.2 and Problem with Wallet 1.2.8 (it suddenly stucks) connection lost, Block behind, Block not accepted, Creep Miner doesn't find nonces. (solved)



  • @BurnMe well i am using windows just not AIO and not solomining, so not sure where the problem creeps out pun intended :D



  • OK i tried pool mining under Linux too. This is working very stable and easy with Linux. I checked the AIO in Windows. But the AIO Software cannot be so configurated like i want to. I want the whole control of plotting and nonce creating, the amount of RAM i am using during plotting. So all this can i do easily with Linux.

    Pool mine just works fine and stable with the creep Miner. But not with solo mining. So i think the changing here is that i don't use the online wallet any more, now im using the local walletl with bring up an Server in my own. And with own local Wallet (Server 127.0.0.1:8125) my problems began. Sometimes stopping mining by CreepMiner, then the wallet block(s) behind the actual block that is used, Block not asccepted and then the CreepMiner stops, Wallet works but creep Miner stops finding nonce with no reasons and so on .....

    So the only thing that i changed on solo mining is that im using the local wallet and therefore i think here is the issue and something wrong and the online wallets are more stable (when no DDos attack).



  • @BurnMe hmm i would still advice to decrease time for deadlines, as i said try it set as 24h. I used 1.2.8 wallet for the longest time now and on test net even used it for solo mining (didnt see any issues but i used really low deadline time).



  • @LithStud Ok thats an good advice. Thats the only thing i didn't testet right now. I will change the deadline to 24 h. Perhaps thats more stable on solo mining. On solo mining i mined nothing (because i'm stoo small) but for testing the small rig is good.

    I will replay again after testing the 24h deadline. It would be crazy if this is solving my problems at all but some things are crazy. Burstcoin is crazy.



  • @BurnMe i will try to remember and post what number i used for solo (~15GB plot file) i think it was 24h but it might be as low as 6h :D since solo mining anything above 1h doesnt really give you anything anyways (1h in case something goes wonky in network and nobody has a good deadline)



  • @LithStud Ok, thanks.

    right now sitting in front of the terminals i see what how my issues comes together

    1. First step
      The Wallet terminal brings the message: Block not accepted

    2. Second step
      At the same time myCreepMiner gets stucked and stops without any messages. I hangs up.

    3. Third step
      Restarting the CreepMiner and i can see that the miner is resuming the same block at exact the block it gots stuck and stopped (at exact the same Block the Wallet terminal said Block not accepted)

    4. Fourth step
      I have to restart first Wallet then after that restart the miner. And then the block is synchronized again until the next message Block not accepted.



  • @BurnMe man that sounds like a real struggle.

    I don't exactly know what "Block not accepted" means, I just found the message in this file of the wallet: https://github.com/burst-team/burstcoin/blob/master/src/java/nxt/BlockchainProcessorImpl.java.
    Maybe a wallet-developer knows more about this (@luxe, @daWallet maybe?).
    For me it looks like there is an error while verifying a block.

    Maybe I can help on 2. Can you please send me the log file of the miner when 2. occurs, so I can see what exactly is happening on the miners side.

    Is the error "Block not accepted" also showing up without the miner connected (only the wallet running)?

    Something you can try is the new branch I pushed yesterday: https://github.com/Creepsky/creepMiner/tree/unstuck-reader.



  • @Creepsky45 i know for a fact that in certain situations wallets API gets stuck for couple minutes and the api calls gets timedout, sadly i have no idea whats causing it. Why it fixes itself after couple minutes not sure either, maybe there are something that detects stuck api and just restarts it, but thats just guessing from my part.



  • This post is deleted!


  • This post is deleted!


  • @BurnMe

    Hi folks,

    i got a small solution for my problems with solo mining, here my results for alle those newbies who want to solo mine with Linux.

    Actually the only Linux that is working for mining with CreepMiner is the Debian based Mintlinux LMDE Betsy. (I don't why but with alle other Versions the miner doesn't find noncec, it could be a special setting in Linux but now i don't know another solution.) Now first time i'm testing over 16 hours withou any errors :) (using the development Version of CreepMiner)

    You have to wait for your wallet to sync. So when it crashes and you restart the wallet after some hours or even more its normal that the wallet is some blocks behind. It just needs time to sync.

    On Solo mining always use http:127.0.0.1:8125 in the url settings. https doesn't work.

    Keep your system time in sync with a good time server (search google for ntpdate and Linux if want to know how to set new time servers, all in all i think Linux has a good time sync on standard installation)

    1. The message "Block not accepted" in the wallet terminal ist an Information, it could be from another user who isn't in sync with time. Or you are the user who is out of time

    6.Don't forget to forward the port in your Router.

    So let me know how you configured your Linux and what Linux Version you are using on solo mining. Perhaps we can create a how to for Linux. You can tell your settings or correct me.

    Can anybody send a step by step how to install jminer on Linux ?



  • Hi with the new development branch of CreepMiner all problems are gone and it's working without any problems. The wallet 1.2.8 seems to be stable too and running without any problems.

    I think it was a bad (bug) communication between the Wallet and the CreepMiner, whatever :) my problems are fully gone.

    Thanks to all for help and explanations how the wallet is working and how to configure.


Log in to reply
 

Looks like your connection to Ⓑurst - Efficient HDD Mining was lost, please wait while we try to reconnect.