New Wallet Version 1.2.7



  • @crutsy quick question. are you using my Mod (ShowMyTradesOnly)? If not this behaviour is really strange as ther wasnt anything done in asset exchange ui. What browser are you using?


  • admin

    @LithStud I tested without the Mod and could reproduce it, maybe something in index.html ... sadly i'm more in java than js/html, so i can not really help in this case.



  • @luxe yea i am looking into whats changed at index.html at the moment. The issue is the modal doesnt fade out? if someone could copy paste whole index.html source when this happens from inside the right click->inspect on google chrome it might help.. maybe :D



  • @LithStud Haven't tried your mod yet. I am using chrome. I will try later on to copy the index.html for you later. (very busy today)

    @luxe Thank You, I'm not worried about it just wanted to share the bug lol



  • @crutsy its ok i did a bit of my own assets buying :D so i got the html :)

    @daWallet @luxe identified a problem for some reason two modal-backdrop divs are generated and during removing one is left (while using cancel this doesnt goes sides it does once pressed submit. Probable reason is one of the models gets changed or something and becomes loose from whatever called it and imposible to remove for that process). Its still a mystery for my why this happens in new version and not old.

    EDIT: problem found and fixed :) will upload to github and put in here :) together with mod



  • FIX: https://drive.google.com/open?id=0BwcSHMRpSHeieXRVZENidzVmZkk

    your getting the ShowMyTradesOnly mod with it as well :) as far as i can tell it didnt introduce any other bugs (it was a problem with duplicate scripts). But as allways whatever comes from me comes with a tag "Use at your own risk" ;)

    Happy trading.



  • @LithStud
    This is simply great. Thank you for the fix! Thank you for contributing.

    Give this man an applause.

    alt text



  • @daWallet on github i added a comment on the index.html about why this happened with some thoughts ;)



  • While this fix was easy i have another way more troublesome problem :) after some time running this happens
    0_1479581227620_blockchain_problem.jpg

    didnt notice time when it stops responding (did i mention wallet tabs stops loading information?) but after it drops that bottom error it starts working again (i guess restarts some process).

    could it be a problem with java on my side (my java updates stoped working long time ago after using java bundles for devs :D)?


  • admin

    @LithStud please make a pull request for that ui fix, i already fixed it in release, but i want to merge it to source, too. Thanks a lot for fixing it.

    Users with the issue can just re-download 1.2.7 and copy html folder over the old one.

    The above is a timeout exception, that does not get caught, so the stacktrace shows up in logs ... not sure what causes the timeout, maybe just a busy pc.



  • @luxe i have made the pull, since its on same repository as the mod it got included in pull request by default. On github i use LithMage username also you can see my beardy noggin there :) so nice to meet you :D


  • admin

    @LithStud Thanks merged it, other changes will be included in a next version. Anyone want to test/use them, can always also download/use html folder from sources.



  • @crutsy said in New Wallet Version 1.2.7:

    @luxe I think there is a minor bug. When I place a buy or sell order on the asset exchange it goes through but the window hangs after the popup goes away. The shaded grey stays and you cannot click on anything. Simply reloading the window and signing back in works good and you can see the transaction was processed.

    Has anyone else experienced this?

    Nothing to worry about just a little irritating is all lol

    @luxe From my side this happens to me also when I try to add an asset...
    Another bug maybe. When I click on the transactions filter button in "transactions" section simply nothing happens...



  • @Dario's-wallet you mean that list selection where you can filter out for eg. Asset Transfer and etc? It work for me fine, so it might be something else.



  • @Dario's-wallet The first day of the 1.2.7 release had this issue. We fixed it. Download 1.2.7 again and replace the /html/ folder.


  • admin

    @Dario-s-wallet Did re-download fixed 1.2.7 solve your issue?



  • I have been having issues even on 1.2.7.1... Will try a re install. Issues started after buying a couple shares of a asset. Always use local wallet, will try blockchain redownload, after reinstall, but I am plotting a drive right now so I need to wait for that to finish.



  • @LithStud @daWallet @luxe YES! With 1.2.7(.1) all fixed! Thanks devs :-*


Log in to reply
 

Looks like your connection to urst - Efficient HDD Mining was lost, please wait while we try to reconnect.