HowTo use OpenCL/GPU for accelerated snyc. with blockchain


  • admin

    Open /conf folder within your burstcoin directory ...

     ../burstcoin-1.2.6/conf
    

    Create a new file with name:
    'nxt.properties'. (All settings made in there will overwrite the default.)

    Open 'nxt.properties' in a text editor and add the following:

    burst.oclVerify=true
    

    The wallet will try to auto-detect the openCL device and platform.

    If auto-detect does not work for you, configure it manualy by adding

    burst.oclAuto=false
    burst.oclPlatform=0
    burst.oclDevice=0
    

    to 'nxt.properties', specify the platform and device you would like to use.

    With a quite good GPU and depending on bandwidth, this will enable you to complete sync from block 0 within 1-2 hours!



  • @luxe i only can get gpu mining with local wallet with full sysnc blockchain???


  • admin

    @burstcoinPT As long as you pool mining you will need no local wallet, on solo your wallet needs to be in sync to mine of cause. But thats not the point of this thread.


  • admin

    Just to proof ... here is my complete sync from block 0 ... (~ 1 hour and 18min.)
    0_1469040694263_sync.png

    Downloaded data for complete sync:
    0_1469040753076_volume.png

    Blocks up-to-date:
    0_1469040789074_blocks.PNG


  • admin

    @luxe Nice one. This is the record so far. Who can beat it? x)


  • admin

    @daWallet just installed my new 480x ... time to break the 'record' ...


  • admin

    Better late than never ... just completed a re-sync of burstcoin wallet 1.2.8 ...

    Complete sync in ~1h 38min

    Compared to previous test, to block 250000 ~ 1h 12min

    I downloaded wallet from github and added a nxt.properties file to /conf folder, to enable openCL.

    nxt.properties content

    burst.oclVerify=true
    burst.oclAuto=false
    burst.oclPlatform=1
    burst.oclDevice=0
    

    0_1488117621255_sync.png 0_1488117703075_volume.png 0_1488118924264_db.PNG

    Btw. i have quite slow internet connection and was running jminer and my displays to same GPU, while sync was processing ...


Log in to reply
 

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.