Trying to start plotting with gtx 1080ti



  • Hello guys,

    my setup is a 16gb ram, gtx 1080ti, 5x 8tb seagate.
    for software i'm using the latest plotter gpuplotter 4.1.1

    My question is, is it normal that the plotter stops showing you the speed and percentage when it reached the staggersize? And is it still working and i just need to wait?



  • @Aisti57, hello. You didn't mention any errors being reported, so I'll assume your plot settings are good. I'm guessing that you mean that the speed and percentage values are still visible, but not updating.

    I have a similar setup (I use a 1060) and it update the values as it fills the RAM you assigned with your staggersize value. Once the RAM is full, the software will write the data out to the hard drive. During this time the values don't update. Once the ram is available again, the plotting software will appear to wake up and will start updating the displayed values.

    You may be experiencing extremely slow write times due to using the Seagate 8TB drives. They use a less costly type of drive known as SMR, which stands for Shingled Magnetic Recording. This makes them awful to plot (they hate short bursts of writing), but they work just fine once you are mining.

    You can do a few things to the drives to help. I format them NTFS with Allocation Unit Size set to 64 kilobytes. You'll definitely want to right click on the drive and go to Properties ->Hardware ->Properties ->Change Settings ->Policies. Select "Better Performance" and check "Enable write caching on the device". I also go to properties and turn of indexing.

    I actually plot smaller plot files (about 2TB) sized so a few of them almost fully fill the hard drive. I plot these to a much faster PMR (normal) hard drive that runs at 7200 rpm. When the plotting is done I'll move the files to the SMR drives. The property changes I mentioned above still apply if you do this...I would always do these with SMR drives.



  • @Evo Thanks a lot! When i was buying these hdds i didn't know at what should i look. I will try these sittings for my other drives but first i will wait until my first is finished. Hopefully it will not take too long.



  • Aisti57
    i had this same problem
    as i was bat file i used had direct as default
    use buffer instead of direct and it may work



  • @burstminergrow Have you tried to wait all this time until it's finished or isn't it finishing at all?
    Now i still keep it running but I'm worried it will take weeks without knowing it's gonna work:S



  • I have a strange problem, because when I copy files on my network drive I get about 80-100 MB/s. If I start plotting and it reaches the staggersize, the writespeed of the plot file from RAM to the network drive is just about 5-6 MB/s. Somebody an idea?



  • @Evo said in Trying to start plotting with gtx 1080ti:

    @Aisti57, hello. You didn't mention any errors being reported, so I'll assume your plot settings are good. I'm guessing that you mean that the speed and percentage values are still visible, but not updating.

    I have a similar setup (I use a 1060) and it update the values as it fills the RAM you assigned with your staggersize value. Once the RAM is full, the software will write the data out to the hard drive. During this time the values don't update. Once the ram is available again, the plotting software will appear to wake up and will start updating the displayed values.

    You may be experiencing extremely slow write times due to using the Seagate 8TB drives. They use a less costly type of drive known as SMR, which stands for Shingled Magnetic Recording. This makes them awful to plot (they hate short bursts of writing), but they work just fine once you are mining.

    You can do a few things to the drives to help. I format them NTFS with Allocation Unit Size set to 64 kilobytes. You'll definitely want to right click on the drive and go to Properties ->Hardware ->Properties ->Change Settings ->Policies. Select "Better Performance" and check "Enable write caching on the device". I also go to properties and turn of indexing.

    I actually plot smaller plot files (about 2TB) sized so a few of them almost fully fill the hard drive. I plot these to a much faster PMR (normal) hard drive that runs at 7200 rpm. When the plotting is done I'll move the files to the SMR drives. The property changes I mentioned above still apply if you do this...I would always do these with SMR drives.

    out of curiosity why are you suggesting 64kb allocation size, I ran tests last night with the 512/4096/64k and I showed no real difference between 4k and 64k but DID show a difference between 512 and 4k, likely because drives today come with native 4k and are merely emulating 512 for legacy support... but have you actually measured performance difference yourself between say 4k native and 64k? because I notice no measurable difference between writing or reading 1TB plots at the end of the day... so I'm wondering if you've actually done tests or are just working off the suggestions of others to set large allocation sizes?

    when testing, I was using optimized 1TB sized files with GPU miner for the best transfer rates, I also ran crystaldiskmark to test differences in allocation size, and I came up with the same results, native 4k and 64k show practically no difference, but there is a measurable performance difference between 512 for legacy and native 4k... but yeah, ultimately I am curious why you suggest 64k allocation size, and if it was directly tied to your own testing or just commonly repeated things websites says about large files (for which most don't show they did any actual testing, they just repeat the mantra others are so used to saying)... even when I've done gigantic SQL stuff for other applications I don't see much difference between a 4k native and 64k allocation for performance, in fact sometimes the 64k performs a fraction of 1% less than 4k, so I've just never seen much reason to go above what the HDD supports natively...



  • @Darkbane, it's possible that the 4K times are nearly indiscernible from the 64K given the various read ahead schemes, caching, file-system optimizations, etc.

    But at the end of the day, a file is stored as a series of clusters/allocation units, each of which is examined in turn when the file is being read. Smaller cluster sizes are great for smaller files; who wants to write a 1K file to the disk only to find out that it takes up 64KB on the platter?

    But Burst plot files all qualify as very large files. I can store mine with 4K clusters or 64K, but I choose the larger size because there are 16 times less entries in the MFT per file and 16 times less overhead involved with reading the same data. Is it noticeably faster? Maybe yes, maybe no. Is it more efficient for Burst plot files? The math says it is.



  • @BloodhunterD It will speed up at the end. During the start it is writing the Scoops and optimizing the entire file. Then at the end your card will be maxing out its Nonces as it fills them.

    I had this happen on other cards too. I just use CPU now. I also use less than half of my RAM so that I can write while I create Nonces. Using all the RAM means you fill that buffer with Nonces and then Write. When you could be writing while creating Nonces. You just need to balance the CPU usage and I can write good with 10 of my 12 threads. I use a 10GB RAM setting on a 32GB total ram. It never stops writing and creating Nonces and the writing finishes before the Nonces of the next buffer are started.



  • @CryptoNick said in Trying to start plotting with gtx 1080ti:

    @BloodhunterD It will speed up at the end. During the start it is writing the Scoops and optimizing the entire file. Then at the end your card will be maxing out its Nonces as it fills them.

    I had this happen on other cards too. I just use CPU now. I also use less than half of my RAM so that I can write while I create Nonces. Using all the RAM means you fill that buffer with Nonces and then Write. When you could be writing while creating Nonces. You just need to balance the CPU usage and I can write good with 10 of my 12 threads. I use a 10GB RAM setting on a 32GB total ram. It never stops writing and creating Nonces and the writing finishes before the Nonces of the next buffer are started.

    perhaps you were using the older GPU plotter version, because the 4.1.1 version I use that fixes the "hang" issues someone report about slowdowns and such, has been resolved... in the picture below, you can see just how little memory I use, and I am able to sustain 28019 nonces/minute in direct mode, optimized plots, and I sustain that a couple minutes into the hours long sessions once the system figures out what its doing and reflects that value it holds steady all the way to the end, where it just ends, it no longer pauses or slows down before during or after...

    (I also attribute a lot of this performance to the HDD's themselves, if they couldn't choke down that much data at once, I certainly wouldn't be doing this well)

    0_1499067903164_1000GB at 28019 nonces.png



  • @Darkbane said in Trying to start plotting with gtx 1080ti:

    @CryptoNick said in Trying to start plotting with gtx 1080ti:

    @BloodhunterD It will speed up at the end. During the start it is writing the Scoops and optimizing the entire file. Then at the end your card will be maxing out its Nonces as it fills them.

    I had this happen on other cards too. I just use CPU now. I also use less than half of my RAM so that I can write while I create Nonces. Using all the RAM means you fill that buffer with Nonces and then Write. When you could be writing while creating Nonces. You just need to balance the CPU usage and I can write good with 10 of my 12 threads. I use a 10GB RAM setting on a 32GB total ram. It never stops writing and creating Nonces and the writing finishes before the Nonces of the next buffer are started.

    perhaps you were using the older GPU plotter version, because the 4.1.1 version I use that fixes the "hang" issues someone report about slowdowns and such, has been resolved... in the picture below, you can see just how little memory I use, and I am able to sustain 28019 nonces/minute in direct mode, optimized plots, and I sustain that a couple minutes into the hours long sessions once the system figures out what its doing and reflects that value it holds steady all the way to the end, where it just ends, it no longer pauses or slows down before during or after...

    (I also attribute a lot of this performance to the HDD's themselves, if they couldn't choke down that much data at once, I certainly wouldn't be doing this well)

    0_1499067903164_1000GB at 28019 nonces.png

    Those are great numbers. If you don't mind sharing, what are the settings in your devices file?



  • @Evo said in Trying to start plotting with gtx 1080ti:

    Those are great numbers. If you don't mind sharing, what are the settings in your devices file?

    below is my devices file, you can see its a minimal setup, heck I'm even making plots on a drive right now while using the GPU to type this message at the same time, I attribute most of my success to the HDD itself since it can sustain the data being thrown at it, but this also shows there is little reason to use a lot of RAM when writing in direct mode with GPU plotter, I'm using next to nothing...

    0 0 1024 16 8192

    and obviously in the photo above you can see my command line for GPU plotter, with my nonce size etc etc, you already have the way superior GPU to my 1050 TI so the bottleneck for you should be the HDD, and if you're able to watch it sustain 30000 nonces for a while but slowly over time it drops to 5000 there is definitely something else to discover for whats causing that, its not the software though, well unless there is a goofy setting somewhere, but as long as your drive can sustain it, you should be able to throw well in excess of my 28000 nonces at it...

    P.S. and just to make sure to mention many times, this is version 4.1.1 which fixed a problem some had with diminishing performance towards the end or beginning...



  • @Darkbane said in Trying to start plotting with gtx 1080ti:

    @Evo said in Trying to start plotting with gtx 1080ti:

    Those are great numbers. If you don't mind sharing, what are the settings in your devices file?

    below is my devices file, you can see its a minimal setup, heck I'm even making plots on a drive right now while using the GPU to type this message at the same time, I attribute most of my success to the HDD itself since it can sustain the data being thrown at it, but this also shows there is little reason to use a lot of RAM when writing in direct mode with GPU plotter, I'm using next to nothing...

    0 0 1024 16 8192

    and obviously in the photo above you can see my command line for GPU plotter, with my nonce size etc etc, you already have the way superior GPU to my 1050 TI so the bottleneck for you should be the HDD, and if you're able to watch it sustain 30000 nonces for a while but slowly over time it drops to 5000 there is definitely something else to discover for whats causing that, its not the software though, well unless there is a goofy setting somewhere, but as long as your drive can sustain it, you should be able to throw well in excess of my 28000 nonces at it...

    P.S. and just to make sure to mention many times, this is version 4.1.1 which fixed a problem some had with diminishing performance towards the end or beginning...

    Thank you for sharing the information. I've only used 4.1.1 on what has become my temporary plotting machine, which has an RX-480 and 10 GB ram. Performance was so-so even though I was writing to a 4 drive RAID 0 array that had great throughput. Not sure what's going on there yet.

    Prior to that I was using 4.0.3 with the 1060. It was OK, but my numbers were not anything like yours. I'm going to plot the next batch of drives on the 1060, see if your device settings work better than mine, and upgrade to 4.1.1. I think that machine has 16GB ram. I'll try it with that and see how 4.1.1 plays with the memory. The drives will be 6TB, 7200 RPM, PMR units, so write speed should not be an issue.

    Again, thank you!



  • @Evo said in Trying to start plotting with gtx 1080ti:

    @Darkbane said in Trying to start plotting with gtx 1080ti:

    @Evo said in Trying to start plotting with gtx 1080ti:

    Those are great numbers. If you don't mind sharing, what are the settings in your devices file?

    below is my devices file, you can see its a minimal setup, heck I'm even making plots on a drive right now while using the GPU to type this message at the same time, I attribute most of my success to the HDD itself since it can sustain the data being thrown at it, but this also shows there is little reason to use a lot of RAM when writing in direct mode with GPU plotter, I'm using next to nothing...

    0 0 1024 16 8192

    and obviously in the photo above you can see my command line for GPU plotter, with my nonce size etc etc, you already have the way superior GPU to my 1050 TI so the bottleneck for you should be the HDD, and if you're able to watch it sustain 30000 nonces for a while but slowly over time it drops to 5000 there is definitely something else to discover for whats causing that, its not the software though, well unless there is a goofy setting somewhere, but as long as your drive can sustain it, you should be able to throw well in excess of my 28000 nonces at it...

    P.S. and just to make sure to mention many times, this is version 4.1.1 which fixed a problem some had with diminishing performance towards the end or beginning...

    Thank you for sharing the information. I've only used 4.1.1 on what has become my temporary plotting machine, which has an RX-480 and 10 GB ram. Performance was so-so even though I was writing to a 4 drive RAID 0 array that had great throughput. Not sure what's going on there yet.

    Prior to that I was using 4.0.3 with the 1060. It was OK, but my numbers were not anything like yours. I'm going to plot the next batch of drives on the 1060, see if your device settings work better than mine, and upgrade to 4.1.1. I think that machine has 16GB ram. I'll try it with that and see how 4.1.1 plays with the memory. The drives will be 6TB, 7200 RPM, PMR units, so write speed should not be an issue.

    Again, thank you!

    yeah if its a PMR drive like mine, I don't see any reason you shouldn't be able to tear through that at speeds better than my 1050 TI using my low settings... start low and work your way up... also make sure to review my photo and try my command line as well to a temporary folder, just to see if you can achieve the speed, you can futz with the ID, start, nonce, stagger after you see how it performs, but I don't see any reason why you shouldn't be able to get superior performance with a 1060/RX480...

    my HDD were my saving grace once I figured out the correct settings for my GPU, but if I followed what others did with giant massive memory usage, I'd have gotten the same disappointing results they did, so perhaps, less really is more.. (just make sure if you copy my command line exactly you make sure to delete that plot, mining for me isn't what you had in mind, plus I already have that plot) good luck!!!

    with that RAID0 setup I would imagine an RX480 with all those shaders should be able to triple my performance, hopefully you can tinker and find the right numbers, just remember, don't be afraid to start plots and let them run for 5min to see where the numbers start to average out to, then delete the plot and start over with other settings, until you slowly work your way up to the sweet spot and then see a decline...

    P.S. if you ever decide to sell the RX 480 let me know, I may be interested, unless of course you want the crazy prices people are asking today for used cards because of the lack of supply heh, although I sure wouldn't blame you for selling it for a profit!



  • Hi @Darkbane, the changelog file says that I'm already using the version 4.1.1 (17/06/2017), but I'm going to download it again.

    If I use my SSD (Samsung 840 EVO) for writing a 250 GB Plot with my device settings 0 0 8192 128 4096 it takes 1 1/2 hour (~46 MB/s). For 1 TB, I would need 6 hours. You got it in 2 1/2 hour (~114 MB/s). That's great. I'll try your settings - maybe it helps.

    UPDATE:
    I'm currently trying your settings and the result is that it starts writing the SSD for over 15 minutes with 100-200 MB/s now. The output of the commandline is just:
    0.00% (0/1024000 remaining nonces), 0.00 nonces/minutes, ETA: 1y 49w 4d 2h 40m 0s ... it doesn't change at all.

    I also tested the XPlotter (CPU) with the same settings and 6 threads. He would be doing the 1 TB Plot in the same time like the gpuPlotGenerator. Both ~6 hours.

    I don't know how you do it, but I don't get this values. After it starts with creating nounces (~50,000 nounces/minute), until it starts to write on the SSD or HDD, the progress freezes and if the writing of the first stagger size is finished, it goes down to ~5,000 nounces/minute. I don't know what I'm doing wrong.



  • @BloodhunterD said in Trying to start plotting with gtx 1080ti:

    Hi @Darkbane, the changelog file says that I'm already using the version 4.1.1 (17/06/2017), but I'm going to download it again.

    If I use my SSD (Samsung 840 EVO) for writing a 250 GB Plot with my device settings 0 0 8192 128 4096 it takes 1 1/2 hour (~46 MB/s). For 1 TB, I would need 6 hours. You got it in 2 1/2 hour (~114 MB/s). That's great. I'll try your settings - maybe it helps.

    UPDATE:
    I'm currently trying your settings and the result is that it starts writing the SSD for over 15 minutes with 100-200 MB/s now. The output of the commandline is just:
    0.00% (0/1024000 remaining nonces), 0.00 nonces/minutes, ETA: 1y 49w 4d 2h 40m 0s ... it doesn't change at all.

    I also tested the XPlotter (CPU) with the same settings and 6 threads. He would be doing the 1 TB Plot in the same time like the gpuPlotGenerator. Both ~6 hours.

    I don't know how you do it, but I don't get this values. After it starts with creating nounces (~50,000 nounces/minute), until it starts to write on the SSD or HDD, the progress freezes and if the writing of the first stagger size is finished, it goes down to ~5,000 nounces/minute. I don't know what I'm doing wrong.

    well if you copied my devices.txt settings, what command line did you use to launch the GPU miner itself, did you copy my command line exactly with the 1024 at the end, or did you change it to 8192 or something?

    0 0 1024 16 8192

    gpuPlotGenerator generate direct F:\plots\3514366288793510651_69632001_4096000_1024

    the 1024 at the end of my command line there, did you keep that as well when you tried my settings? but its disturbing that you say its running for 15 minutes without updating anything, it almost sounds like that old problem, when you look at the screen does it say you're using 4.1.1 on it? its hard to keep guessing without being able to see exactly what you typed and what its showing, take pictures man! show us everything happening from the second its launched to ended or when you finally hit ctrl-C to cancel it...

    P.S. also please consider NOT using that SSD, you're just gobbling up the write cycles on it, weren't you using PMR drives, if so, don't use the SSD just to write then copy over, you're slapping that SSD around unnecessarily...



  • @Darkbane Ok, I made a new plot using your settings. The commandline shows after a few seconds a progress, but the current nounces rate is about ~1200 per minute (see screenshot).

    CMD

    As you can see, I use version 4.1.1, but I only get 6-7 MB/s transferred to the HDD. The HDDs are all WD Red 5 TB (WD50EFRX-68MYMN1) cobined as JBOD. If I transfer files directly, I get 80-100 MB/s.



  • @BloodhunterD said in Trying to start plotting with gtx 1080ti:

    @Darkbane Ok, I made a new plot using your settings. The commandline shows after a few seconds a progress, but the current nounces rate is about ~1200 per minute (see screenshot).

    As you can see, I use version 4.1.1, but I only get 6-7 MB/s transferred to the HDD. The HDDs are all WD Red 5 TB (WD50EFRX-68MYMN1) cobined as JBOD. If I transfer files directly, I get 80-100 MB/s.

    well the only thing I notice different from us is our OpenCL usage... I'm on 1.2 and you're on 2.0 it seems... lets try and compare everything else we're doing here...

    I notice you seems to be running this from a regular command prompt, did you just click the batch file to start it up? can you run this from an administrative command prompt as I do with all my plots? you should be able to open an "administrative" command prompt by... start button, windows system, command prompt, right-click on that and slide over to more and then "run as administrator" if I recall... and you will see "Administrator: Command Prompt" as the title of your screen now rather than "C:\windows\system32\cmd.exe" and you can just manually move over to the directory and launch the batch file from there...

    so whats my system and files installed...

    Win 10 Pro
    (this should have little impact)

    Java 32-bit
    (this should have little impact, although I have recently uninstalled it and now only use 64-bit for some new round of testing, and the quick one I just did showed little change with GPU plotter between 32/64-bit... if your Java on the uninstall screen doesn't specifically say 64-bit after it then you are using the 32-bit version)

    Microsoft Visual C++ 2010/2013/2015
    (I can't remember which but I know it was either 2013 or 2015 that had to be installed to make this work, I'm leaning towards 2013 but I've been screwing around with installs so much I can't remember which one I needed for GPU plotter)

    NVIDIA Graphics Driver 382.53
    (I know many times when windows updates itself with a major system update, it will revert your OpenCL back to its OpenCL, so you may have to do what others have done, and reinstall your GPU drivers each time windows does a major system update, although at this point you're using AMD drivers and I'm using NVIDIA so I'm not sure if its the same issue or how to address this one to get us both on OpenCL 1.2 and it really shouldn't make much difference to be honest, but perhaps its displaying your driver but using the windows default OpenCL like some of us have issues with rather than your manufacturers driver, I assume its using your driver)

    so I guess we have reached the point where my settings do nothing for you, and we're left with, well what on earth could it be... so thats why I am sharing the software I am using since maybe we can find something along the way that might be affecting your performance, clearly you should be CRUSHING what I get with your GPU, I can't believe nobody else with the same GPU hasn't chimed in yet, there must be others out there using one who can steer this in the correct direction...



  • @Darkbane First of all, I wanna to say thank you for you help so far :)

    I run it as admin, but it's also slow. I think, it's just a problem with the transfer from RAM to the HDD, because when I tried a big stagger size, the nounces were created fast, but it all slows down, when the writing starts. With a small stagger, it is slow from the beginning.

    I have:

    • Windows 10 Pro
    • Java 8 Update 131 (64 bit)
    • Visual C++ 2005 / 2008 / 2010 / 2012 / 2013 (all Versions 32 and 64 bit)
    • AMD Graphics Driver 17.10.3211 (for Radeon R9)


  • @BloodhunterD said in Trying to start plotting with gtx 1080ti:

    @Darkbane First of all, I wanna to say thank you for you help so far :)

    I run it as admin, but it's also slow. I think, it's just a problem with the transfer from RAM to the HDD, because when I tried a big stagger size, the nounces were created fast, but it all slows down, when the writing starts. With a small stagger, it is slow from the beginning.

    I have:

    • Windows 10 Pro
    • Java 8 Update 131 (64 bit)
    • Visual C++ 2005 / 2008 / 2010 / 2012 / 2013 (all Versions 32 and 64 bit)
    • AMD Graphics Driver 17.10.3211 (for Radeon R9)

    see that slow transfer from buffer to HDD is why I used such low settings to force it to write to the drive, otherwise I would watch the nonces pause until the entire buffer was written to drive, which as you can imagine, destroyed my averages, and only after I whittled things down to my settings, did I finally see a constant drive usage without waiting for the buffer to fill then dump while it pauses nonces...

    I can't pretend to understand how the plotter works, but at this point we look like two monkeys sitting in front of a banana wondering how to open it, somehow the answer is going to be as easy as "just peel it" but neither of us have peeled this one before... where is that third monkey we need who has done it with your GPU already...

    think we might have reached a point where we need the developers of the software to chime in and explain whats going on, and why its going on, or let them sit with us next to the banana and wonder what to do...

    (since you've tried my settings and your higher settings, what are the odds using even lower settings might work for you, thats basically all I did to find my settings, constant trial and error up and down, until I finally settled on this, it seems we just keep circling back to the HDD writing being the lynch pin though, and these are drives connected direct to to the sata controller right, not external devices in some wacky backup device that might be doing its own throttling of some sorts?)


Log in to reply
 

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.