Plot file scanning speed


  • admin

    @burstbubble Are you sure it's 4.1.1? The behaviour you're describing is typical of prior versions.

    Can you post a screen shot including the command line, and everything up to where it's currently reporting progress.



  • 0_1498890481927_Clipboard01.jpg Here is the screenshot...any ideas?



  • @burstbubble Your stagger size is incorrect, try 8448 instead of 8192.

    Your stagger must divide the number of nonces by a multiple of 8.

    1858560 / 8 = 232320

    The factors of 232320 are (http://www.numberempire.com/1858560)
    1, 2, 3, 4, 5, 6, 8, 10, 11, 12, 15, 16, 20, 22, 24, 30, 32, 33, 40, 44, 48, 55, 60, 64, 66, 80, 88, 96, 110, 120, 121, 128, 132, 160, 165, 176, 192, 220, 240, 242, 256, 264, 320, 330, 352, 363, 384, 440, 480, 484, 512, 528, 605, 640, 660, 704, 726, 768, 880, 960, 968, 1024, 1056, 1210, 1280, 1320, 1408, 1452, 1536, 1760, 1815, 1920, 1936, 2112, 2420, 2560, 2640, 2816, 2904, 3072, 3520, 3630, 3840, 3872, 4224, 4840, 5120, 5280, 5632, 5808, 7040, 7260, 7680, 7744, 8448, 9680, 10560, 11264, 11616, 14080, 14520, 15360, 15488, 16896, 19360, 21120, 23232, 28160, 29040, 30976, 33792, 38720, 42240, 46464, 56320, 58080, 61952, 77440, 84480, 92928, 116160, 123904, 154880, 168960, 185856, 232320, 309760, 371712, 464640, 619520, 929280, 1858560

    8448 is in this list 8192 is not.

    Cancel your plot, then try it again with stagger size of 8448
    (Be sure to permanently delete the old plot first)

    Let us know if you have an issue.



  • @iKnow0 Now it hangs at 0.06% :D...



  • @Darkbane said in Plot file scanning speed:

    @x40st said in Plot file scanning speed:

    Hi, I'm newbie here, first time posting :)
    I guess I'm having problems with scanning plot files, have tried 3 different miners, thanks to their creators they all are easy to use

    1. creepMiner (https://github.com/Creepsky/creepMiner) ~ 20 mb/s
    2. jminer (https://github.com/de-luxe/burstcoin-jminer) ~ 50 mb/s
    3. Blago's miner (https://github.com/Blagodarenko/miner-burst/releases) ~ 30 mb/s

    I've seen many posts of others that report 120-250 mb/s and I cannot figure out what I'm doing wrong

    I have 2 plot files for now, 1.9tb and 5.3tb

    and here are my hardware specs

    Asus h270f motherboard
    Intell 7700k
    32GB RAM(ddr4)
    MSI GTX 770 2gb Graphic card
    8TB WD external HDD

    HDD is connected to USB3 port, actually tried with all existing USB3 ports on my machine, even tried with USB 3.1 port

    what i'm doing wrong? :-/

    Thanks everyone in advance.

    (someone already mentioned optimizing as a first step, thats likely it, but just in case, lets explore some other reasons why you may be getting varied results or see others perform better than you, but PLEASE start with optimizing, always try to create plots in direct mode or optimized by default, its just so much better)

    some miners are using multiple hard drives, so the read times they are posting are depending on the software combined into a single stream, some people get 650MB/s because they have 16 hard drives daisy chained on USB when each individual drive is only reading at lets say 80MB/s in this scenario...

    also it could be the software you're using only allows your system to read so much data at a time, for example, when I use the one CPU miner with AVX I am only able to get 80MB/s reads while someone using the same miner with AVX2 is able to get 120MB/s reads because the software is able to use the CPU in different ways, which will lead the the same HDD performing at different rates...

    the next could just be your hard drive isn't capable of doing anymore, it could be a windows setting is set to conserve and restrict what your drive is doing because you want power savings over performance, there are a couple often mentioned things related to this such as changing the write-cache to be enable, or selection high performance in your power settings, etc etc etc...

    ultimately I don't know why your drives are performing different than their drives, but there are numerous reasons, having the i7-7700k processor means you should be able to use AVX2 instructions, so when you use a miner that has a different file for that, I suggest using it, if you're using the GPU miner then you could just be hitting a sheer wall of performance for your particular drive, or maybe you can tinker with the windows settings to ensure none of them are restricting your performance to conserve power, etc etc etc...

    what you could do, is also down crystaldiskmark and test your drives speed, so you get a baseline of what its capable of, not what you should expect from mining, but at least you know its capable of "x" even if mining will only get you "y"... I say this because my drives can get 240MB/s reads sequentially, however I will get roughly 160MB/s on average while reading using the particular GPU miner, but if I were to use the CPU miner, I would be limited to 80MB/s because I am only able to use AVX instructions and thus my performance bottleneck is the processors ability to use modern day tools... anyhow hope this helps you track down things and find a solution for yourself...

    P.S. optimizing may be your solution because your hard drive is playing wack-a-mole jumping around trying to grab bits and pieces of data to string together the information it needs, which may be slowing your whole process down as each device is waiting for your drive to provide it what it wants... but I added in all the other information above since someone else already mentioned that... (just in case)

    Thank you very much for the detailed answer!
    I will report back with results!



  • I'm back with the results, so here they are

    with my hardware I'm getting about 80 MB/s on EVERY plot file, so in my case when I have 3 x 8Tb HDDs Blago miner shows 240 MB/s constantly
    I can only guess that miner reads my plot files in parallel and that is why it shows 240 MB/s and not 80

    BTW I have optimized one of that 8Tbs and yet cannot see any difference in scanning speed in comparison to other 2 x 8Tbs



  • Did you make sure your drive settings are all correct?

    I'm assuming you are using Windows. The snapshots below are from Windows 10. Indexing can slow things down, and you need to sure that the removal policy is "Better Performance". Often it defaults to "Quick Removal", which slow things down.

    Go to Explorer, select one of your drives, right click, and select properties. Then you should be able to use the snapshots below as guides to allow you to check/change the drive settings:

    0_1504365930989_P1.png

    0_1504365936612_P2.png

    0_1504365947500_P3.png

    0_1504365954549_P4.png

    Make yours look like this:

    0_1504365959478_P5.png



  • @Evo said in Plot file scanning speed:

    Did you make sure your drive settings are all correct?

    I'm assuming you are using Windows. The snapshots below are from Windows 10. Indexing can slow things down, and you need to sure that the removal policy is "Better Performance". Often it defaults to "Quick Removal", which slow things down.

    Go to Explorer, select one of your drives, right click, and select properties. Then you should be able to use the snapshots below as guides to allow you to check/change the drive settings:

    after someone plots the HDD's they shouldn't gain any performance in the future when reading plots with this enabled, so its safer to just disable it after the plot has been written to the HDD...



  • Is this panel accessible if the drive doesn't have a letter? I have 72 drives with no drive letters??



  • @rds Yes. Start "Computer Management" in Windows then expand Storage in left hand side and select Disk Management. The right hand pane will be updated to show all your disks, right click on the bit that says "Disk # Basic XX TB Online" and select Properties. You'll then get to the same properties panel.


Log in to reply
 

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.