Failed Writefile (code = 2) & (code = 1167)



  • I am testing out an SAS Controller and I suspect it is having problems with XPlotter. I haven't tried any other plotter yet but I keep getting "Failed Writefile (code = 2)"

    I then change the stripe size and use different block sizes and I get Failed Writefile (code = 1167)

    So I imagine it is something to do with the Sector size since I can write to the drive fine.

    I am striping 8 Drives with a 128K stripe. And using 4096 as the sector size. I tried 64k stripe also.

    XPlotter actually creates the file and uses the entire drive it just doesn't start to fill the Plot after the first set of Nonces are made.

    Update!
    Failed in JBOD on one drive but then writes fine on another. I also have some drives with EFI partitions that are embedded on the drive. There are 4 on one channel and 4 on the other. I unplugged one SAS channel and it writes on that channel. I will now test on the other channel and see if it writes without the other channel attached. All in JBOD so I know it has nothing to do with the stripe size now. Might be bad sectors too since the drives were used and I have no history.


  • Mod

    @CryptoNick
    ERROR_DEVICE_NOT_CONNECTED
    1167 (0x48F)
    The device is not connected.



  • I figured it out, finally! There is a NAS problem when the volume mounts. I have to go into DiskPart to get the info and clear the READONLY attrib. For some reason every time you boot it reverts the NAS to READONLY:
    DISKPART
    LIST VOLUME
    SELECT VOLUME x
    DETAIL VOLUME
    ATTR VOLUME CLEAR READONLY


Log in to reply
 

Looks like your connection to Burst - Efficient HDD Mining was lost, please wait while we try to reconnect.